4.0.0 org.apache.felix org.apache.felix.http.parent 9 ../parent/pom.xml Apache Felix Http Jetty org.apache.felix.http.jetty 3.4.4 jar scm:svn:http://svn.apache.org/repos/asf/felix/releases/org.apache.felix.http.jetty-3.4.4 scm:svn:https://svn.apache.org/repos/asf/felix/releases/org.apache.felix.http.jetty-3.4.4 http://svn.apache.org/viewvc/felix/releases/org.apache.felix.http.jetty-3.4.4 8 9.3.20.v20170531 org.apache.felix maven-bundle-plugin 3.3.0 ${jetty.version} org.apache.felix.http.jetty.internal.JettyActivator org.osgi.service.http, org.osgi.service.http.context, org.osgi.service.http.runtime, org.osgi.service.http.runtime.dto, org.osgi.service.http.whiteboard, org.apache.felix.http.api, org.eclipse.jetty.*;-split-package:=merge-first;version=${version;===;${jetty.version}}, org.apache.felix.http.jetty org.apache.felix.http.base.*, org.apache.felix.http.jetty.* org.apache.commons.* javax.imageio;resolution:=optional, javax.sql;resolution:=optional, org.slf4j.*;resolution:=optional, org.ietf.jgss;resolution:=optional, org.mortbay.log;resolution:=optional;version="[6.1,7)", org.mortbay.util.ajax;resolution:=optional;version="[6.1,7)", org.osgi.service.cm;version="[1.3,2)", org.osgi.service.event;version="[1.2,2)", org.osgi.service.log;version="[1.3,2)", org.osgi.service.metatype;version="[1.1,2)";resolution:=optional, org.osgi.service.useradmin;resolution:=optional, org.apache.felix.http.api;version="[2.0,2.1)", org.osgi.service.http;version="[1.2.1,1.3)", org.osgi.service.http.context;version="[1.0,1.1)", org.osgi.service.http.runtime;version="[1.0,1.1)", org.osgi.service.http.runtime.dto;version="[1.0,1.1)", * org.osgi.service.metatype;version="[1.1,2)" osgi.implementation;osgi.implementation="osgi.http";version:Version="1.0"; uses:="javax.servlet,javax.servlet.http,org.osgi.service.http.context,org.osgi.service.http.whiteboard", osgi.service;objectClass:List<String>="org.osgi.service.http.runtime.HttpServiceRuntime"; uses:="org.osgi.service.http.runtime,org.osgi.service.http.runtime.dto" osgi.contract;filter:="(&(osgi.contract=JavaServlet)(version=3.1))" true javax.servlet javax.servlet-api org.osgi osgi.core org.osgi org.osgi.service.cm 1.5.0 provided org.osgi org.osgi.service.event 1.3.1 provided org.osgi org.osgi.service.metatype 1.3.0 provided org.osgi org.osgi.service.useradmin 1.1.0 provided org.eclipse.jetty jetty-servlet ${jetty.version} org.eclipse.jetty jetty-server ${jetty.version} org.eclipse.jetty jetty-util ${jetty.version} org.eclipse.jetty jetty-jmx ${jetty.version} org.eclipse.jetty jetty-security ${jetty.version} org.eclipse.jetty jetty-webapp ${jetty.version} org.eclipse.jetty.websocket websocket-servlet ${jetty.version} org.eclipse.jetty.websocket websocket-server ${jetty.version} org.apache.felix org.apache.felix.http.api 3.0.0 org.apache.felix org.apache.felix.http.base 3.0.18 commons-fileupload commons-fileupload 1.3.2 commons-io commons-io 2.5 org.osgi org.osgi.service.log 1.3.0 test